안드로이드 스튜디오 Gradle 업데이트 오류

프로그래밍/안드로이드 2021. 8. 6. 11:09
반응형

안드로이드 스튜디오에서 작업중 Gradle 업데이트가 있다고 알림이 떠서 업데이트를 했는데, 다음과 같은 오류가 발생하였습니다.

Cannot find AGP version in build files.


Gradle 버전 4.2.2에서 7.0.0으로 업데이트 도중에 오류가 발생하였습니다.

해결 방법은 간단 하였습니다.

"File" 메뉴의 "Sync Project width Gradle Files"를 실행하니 업데이트가 되었습니다.


추가로 현재 프로젝트에 설정되어 있는 Gradle 버전을 알아보는 방법입니다.

"File -> Project Structure..." 를 실행하면 프로젝트에 설정되어 있는 현재 그레이들 버전을 알 수 있습니다.

Gradle Version


다른 방법으로는 build.gradle 파일을 열어보면 버전 정보를 볼 수 있습니다.

dependencies {
    classpath 'com.android.tools.build:gradle:7.0.0'
    classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"
    // NOTE: Do not place your application dependencies here; they belong
    // in the individual module build.gradle files
}


프로젝트에 build.gradle 파일이 두 개가 보입니다.

build.gradle(Project: HelloKotlin)
build.gradle(Module: HelloKotlin.app)


뒤쪽에 "Project"라고 되어 있는 파일이 프로젝트 전체에 영향을 미치는 파일이고, "Module" 이라고 되어 있는 파일은 모듈에만 영향을 미치는 파일 입니다.

안드로이드 스튜디오에서 모듈은 휴대폰, 태블릿, 웨어러블, TV 등 장치별로 만들어집니다. 모듈은 보통 프로젝트를 만들 때 정하는데, 나중에 추가할 수도 있습니다.

반응형

댓글을 달아 주세요